My blog has moved!

You should be automatically redirected in 6 seconds. If not, visit
http://www.macadmincorner.com
and update your bookmarks.

Thursday, December 20, 2007

PowerPoint Crashing in Slide Mode

A few months ago, someone posted comments on my "OS Images vs. The Santa Rosa MacBook Pro 2.2/2.4Ghz" article stating that PowerPoint would crash in slide mode on non-Santa Rosa machines when using an image that was created or updated on a SR machine. At the time, I was unable to reproduce it but now we're seeing it all over.

This issue is caused by the version of OpenGL that is included with Santa Rosa machines. The fix is to replace the /System/Library/Framworks/OpenGL.framework with one from a non-SR OS. I packaged it up and configured the installer to not install on SR machines and only install on 10.4.10 or 10.4.11. I'd post it here, but Apple seems to have some rules against that. :-)

5 comments:

Anonymous said...

This is great, we were running into the same problem and this fixed it. Thanks for sharing!

I realize you can't post the entire package with the OpenGL directory, but can you share the code your package uses to determine which machines to install it on? Thanks!

PatGmac said...

Here is a screen shot of Package Maker that shows the requirements I have set. It is the Leopard version of PM but the same options should be available in earlier versions.

http://patgmac.googlepages.com/opengl.png

mikerose said...

We're working on the same problem here and beginning to think it'll be easier to go 2008 or Leopard... :-(

Have you noticed that after swapping out the OpenGL framework, Photo Booth and Keynote stop working?

b said...

Pat:

Any idea what version(s) of OpenGL might work? I just moved a copy of the OpenGL 1.5.1 framework of a non-SR image, and PowerPoint (fully updated) is still hosed.

b said...

Following up on my own comment, I installed 1.4.16, and it seems to work. Problem is that now DVD Player doesn't run. Sheesh.

Thursday, December 20, 2007

PowerPoint Crashing in Slide Mode

A few months ago, someone posted comments on my "OS Images vs. The Santa Rosa MacBook Pro 2.2/2.4Ghz" article stating that PowerPoint would crash in slide mode on non-Santa Rosa machines when using an image that was created or updated on a SR machine. At the time, I was unable to reproduce it but now we're seeing it all over.

This issue is caused by the version of OpenGL that is included with Santa Rosa machines. The fix is to replace the /System/Library/Framworks/OpenGL.framework with one from a non-SR OS. I packaged it up and configured the installer to not install on SR machines and only install on 10.4.10 or 10.4.11. I'd post it here, but Apple seems to have some rules against that. :-)

5 comments:

Anonymous said...

This is great, we were running into the same problem and this fixed it. Thanks for sharing!

I realize you can't post the entire package with the OpenGL directory, but can you share the code your package uses to determine which machines to install it on? Thanks!

PatGmac said...

Here is a screen shot of Package Maker that shows the requirements I have set. It is the Leopard version of PM but the same options should be available in earlier versions.

http://patgmac.googlepages.com/opengl.png

mikerose said...

We're working on the same problem here and beginning to think it'll be easier to go 2008 or Leopard... :-(

Have you noticed that after swapping out the OpenGL framework, Photo Booth and Keynote stop working?

b said...

Pat:

Any idea what version(s) of OpenGL might work? I just moved a copy of the OpenGL 1.5.1 framework of a non-SR image, and PowerPoint (fully updated) is still hosed.

b said...

Following up on my own comment, I installed 1.4.16, and it seems to work. Problem is that now DVD Player doesn't run. Sheesh.

Thursday, December 20, 2007

PowerPoint Crashing in Slide Mode

A few months ago, someone posted comments on my "OS Images vs. The Santa Rosa MacBook Pro 2.2/2.4Ghz" article stating that PowerPoint would crash in slide mode on non-Santa Rosa machines when using an image that was created or updated on a SR machine. At the time, I was unable to reproduce it but now we're seeing it all over.

This issue is caused by the version of OpenGL that is included with Santa Rosa machines. The fix is to replace the /System/Library/Framworks/OpenGL.framework with one from a non-SR OS. I packaged it up and configured the installer to not install on SR machines and only install on 10.4.10 or 10.4.11. I'd post it here, but Apple seems to have some rules against that. :-)

5 comments:

Anonymous said...

This is great, we were running into the same problem and this fixed it. Thanks for sharing!

I realize you can't post the entire package with the OpenGL directory, but can you share the code your package uses to determine which machines to install it on? Thanks!

PatGmac said...

Here is a screen shot of Package Maker that shows the requirements I have set. It is the Leopard version of PM but the same options should be available in earlier versions.

http://patgmac.googlepages.com/opengl.png

mikerose said...

We're working on the same problem here and beginning to think it'll be easier to go 2008 or Leopard... :-(

Have you noticed that after swapping out the OpenGL framework, Photo Booth and Keynote stop working?

b said...

Pat:

Any idea what version(s) of OpenGL might work? I just moved a copy of the OpenGL 1.5.1 framework of a non-SR image, and PowerPoint (fully updated) is still hosed.

b said...

Following up on my own comment, I installed 1.4.16, and it seems to work. Problem is that now DVD Player doesn't run. Sheesh.