My blog has moved!

You should be automatically redirected in 6 seconds. If not, visit
http://www.macadmincorner.com
and update your bookmarks.

Thursday, July 5, 2007

OS Images vs. The Santa Rosa MacBook Pro 2.2/2.4Ghz

Back on June 5, Apple updated the MacBook Pro to include faster cpu's, LED-backlit display and a video card upgrade. This MBP came with a newer build of 10.4.9 so of course, our image had to be updated. But by the time these actually started shipping to us, 10.4.10 became available. So I updated our image using a Core2Duo iMac and used the combo updater to get it up to 10.4.10. That same day, someone on our team was setting up a new MBP and applied the image that I just updated and it kernel panics upon reboot. Grrr.

So Apple didn't include whatever updates were needed for the 2.2/2.4Ghz MBP's with the 10.4.10 update so I borrowed that new MBP and built the image again by applying my 10.4.9 image which expectedly also kernel panicked, then I "upgraded" it with the discs included, which worked as usual. Boots up fine now. I proceed to do all other updates including the 10.4.10 combo, other application updates etc.

However, one critical mistake was made. We allowed the Macbook Pro Software Update 1.0 to be installed. The description on this update is so vague and doesn't really mention what it is updating. Anyway. Created the image, uploaded to server and configured NetRestore to use the image.

I used an iMac Core2 Duo to test the image (since this is about 95% of our new desktops). Upon boot it gets this screen:

Cropped image of the screen

Using lsbom to view the contents of the Archive.bom file of /Library/Reciepts/MacBookProSoftwareUpdate1.0.pkg I saw that a bunch of Nvidia drivers were updated. I spent a couple hours trying to figure out which one file was causing the problem by reverting some of them to older versions from another iMac but I gave up on that because I didn't want to find out later that there was another file for a different model Mac that needs to be replaced. So I decided to just build the image again without the MBP updater and sure enough, it worked. To confirm that was definately the MBP updater that caused the display problem, I applied the updater again to the MBP and used target disk mode to boot the iMac and sure enough, got the same image as above.

So to summarize, the latest machine right now an image could be built on is the Santa Rosa MBP 2.2 or 2.4Ghz but do not install the MacBook Pro Software Update 1.0. It will render the image useless on other machines.

digg story

8 comments:

Anonymous said...

You may not be in the clear just yet if you have Microsoft Office 2004 Powerpoint users. Your new image will crash Powerpoint when switching to Slide Show view on pre-Santa Rosa machines after updating to Mac OS X 104.10. I'm having to create two intel images becasue of it =(

PatGmac said...

I just tried it and I'm not having this problem. Is there something in your PPT files that would be different such as QT movies?

I used PPT's from here to test.

Would you be able to send me one of your PPT's and I can try it? My email is patgmac at gmail dot com

Anonymous said...

Here's the image recipe:
1. A working 10.4.9 image.
2. Upgraded with Santa Rosa essential software.
3. Upgraded to 10.4.10 (with or without MacBook Pro Software update).

If I restore the above image to any NON-Santa Rosa Mac (tested on 2.3Ghz MacBook Pro and Mac Pro), it causes Powerpint to crash whenever you switch to Slide Show view with any PPT file including new blank PPT files that are created when you open Powerpoint.

Crashreporter reports OPENGL as the thread that crashed.

The crash will NOT occur on Santa Rosa MacBook Pros.

The crash will NOT occur on NON-Stanta Rosa macs with 10.4.9 (8R2218) until you upgrade to 10.4.10 (v1.0 or 1.1).

Please confirm and tell me your joking ; )

PatGmac said...

I used the same procedure to create my image except I had more than essential software checked during the installer (I figured it couldn't hurt). There were a few other items that said "upgrade" and had a file size to them indicating they were in fact being upgraded.

You may have something else going on with your MBP image, perhaps something cached. I would try cleaning caches with something like MacHelpMate.

Anonymous said...

Patrick,
I am having this issue on the English Lab. PPT crashes all lab machines in Slide show view.
Damon

PatGmac said...

Ok, now I'm seeing it all over.
Posted here

John said...

Sorry for butting in to your discussion, but I found you while searching everywhere for talk of this problem. Have you made any progress in figuring out why ppt crashes in view mode on MacBook? I've spoken to both Apple and Microsoft and neither is willing to offer solutions. Thanks.

PatGmac said...

Yes. I posted our solution here

Thursday, July 5, 2007

OS Images vs. The Santa Rosa MacBook Pro 2.2/2.4Ghz

Back on June 5, Apple updated the MacBook Pro to include faster cpu's, LED-backlit display and a video card upgrade. This MBP came with a newer build of 10.4.9 so of course, our image had to be updated. But by the time these actually started shipping to us, 10.4.10 became available. So I updated our image using a Core2Duo iMac and used the combo updater to get it up to 10.4.10. That same day, someone on our team was setting up a new MBP and applied the image that I just updated and it kernel panics upon reboot. Grrr.

So Apple didn't include whatever updates were needed for the 2.2/2.4Ghz MBP's with the 10.4.10 update so I borrowed that new MBP and built the image again by applying my 10.4.9 image which expectedly also kernel panicked, then I "upgraded" it with the discs included, which worked as usual. Boots up fine now. I proceed to do all other updates including the 10.4.10 combo, other application updates etc.

However, one critical mistake was made. We allowed the Macbook Pro Software Update 1.0 to be installed. The description on this update is so vague and doesn't really mention what it is updating. Anyway. Created the image, uploaded to server and configured NetRestore to use the image.

I used an iMac Core2 Duo to test the image (since this is about 95% of our new desktops). Upon boot it gets this screen:

Cropped image of the screen

Using lsbom to view the contents of the Archive.bom file of /Library/Reciepts/MacBookProSoftwareUpdate1.0.pkg I saw that a bunch of Nvidia drivers were updated. I spent a couple hours trying to figure out which one file was causing the problem by reverting some of them to older versions from another iMac but I gave up on that because I didn't want to find out later that there was another file for a different model Mac that needs to be replaced. So I decided to just build the image again without the MBP updater and sure enough, it worked. To confirm that was definately the MBP updater that caused the display problem, I applied the updater again to the MBP and used target disk mode to boot the iMac and sure enough, got the same image as above.

So to summarize, the latest machine right now an image could be built on is the Santa Rosa MBP 2.2 or 2.4Ghz but do not install the MacBook Pro Software Update 1.0. It will render the image useless on other machines.

digg story

8 comments:

Anonymous said...

You may not be in the clear just yet if you have Microsoft Office 2004 Powerpoint users. Your new image will crash Powerpoint when switching to Slide Show view on pre-Santa Rosa machines after updating to Mac OS X 104.10. I'm having to create two intel images becasue of it =(

PatGmac said...

I just tried it and I'm not having this problem. Is there something in your PPT files that would be different such as QT movies?

I used PPT's from here to test.

Would you be able to send me one of your PPT's and I can try it? My email is patgmac at gmail dot com

Anonymous said...

Here's the image recipe:
1. A working 10.4.9 image.
2. Upgraded with Santa Rosa essential software.
3. Upgraded to 10.4.10 (with or without MacBook Pro Software update).

If I restore the above image to any NON-Santa Rosa Mac (tested on 2.3Ghz MacBook Pro and Mac Pro), it causes Powerpint to crash whenever you switch to Slide Show view with any PPT file including new blank PPT files that are created when you open Powerpoint.

Crashreporter reports OPENGL as the thread that crashed.

The crash will NOT occur on Santa Rosa MacBook Pros.

The crash will NOT occur on NON-Stanta Rosa macs with 10.4.9 (8R2218) until you upgrade to 10.4.10 (v1.0 or 1.1).

Please confirm and tell me your joking ; )

PatGmac said...

I used the same procedure to create my image except I had more than essential software checked during the installer (I figured it couldn't hurt). There were a few other items that said "upgrade" and had a file size to them indicating they were in fact being upgraded.

You may have something else going on with your MBP image, perhaps something cached. I would try cleaning caches with something like MacHelpMate.

Anonymous said...

Patrick,
I am having this issue on the English Lab. PPT crashes all lab machines in Slide show view.
Damon

PatGmac said...

Ok, now I'm seeing it all over.
Posted here

John said...

Sorry for butting in to your discussion, but I found you while searching everywhere for talk of this problem. Have you made any progress in figuring out why ppt crashes in view mode on MacBook? I've spoken to both Apple and Microsoft and neither is willing to offer solutions. Thanks.

PatGmac said...

Yes. I posted our solution here

Thursday, July 5, 2007

OS Images vs. The Santa Rosa MacBook Pro 2.2/2.4Ghz

Back on June 5, Apple updated the MacBook Pro to include faster cpu's, LED-backlit display and a video card upgrade. This MBP came with a newer build of 10.4.9 so of course, our image had to be updated. But by the time these actually started shipping to us, 10.4.10 became available. So I updated our image using a Core2Duo iMac and used the combo updater to get it up to 10.4.10. That same day, someone on our team was setting up a new MBP and applied the image that I just updated and it kernel panics upon reboot. Grrr.

So Apple didn't include whatever updates were needed for the 2.2/2.4Ghz MBP's with the 10.4.10 update so I borrowed that new MBP and built the image again by applying my 10.4.9 image which expectedly also kernel panicked, then I "upgraded" it with the discs included, which worked as usual. Boots up fine now. I proceed to do all other updates including the 10.4.10 combo, other application updates etc.

However, one critical mistake was made. We allowed the Macbook Pro Software Update 1.0 to be installed. The description on this update is so vague and doesn't really mention what it is updating. Anyway. Created the image, uploaded to server and configured NetRestore to use the image.

I used an iMac Core2 Duo to test the image (since this is about 95% of our new desktops). Upon boot it gets this screen:

Cropped image of the screen

Using lsbom to view the contents of the Archive.bom file of /Library/Reciepts/MacBookProSoftwareUpdate1.0.pkg I saw that a bunch of Nvidia drivers were updated. I spent a couple hours trying to figure out which one file was causing the problem by reverting some of them to older versions from another iMac but I gave up on that because I didn't want to find out later that there was another file for a different model Mac that needs to be replaced. So I decided to just build the image again without the MBP updater and sure enough, it worked. To confirm that was definately the MBP updater that caused the display problem, I applied the updater again to the MBP and used target disk mode to boot the iMac and sure enough, got the same image as above.

So to summarize, the latest machine right now an image could be built on is the Santa Rosa MBP 2.2 or 2.4Ghz but do not install the MacBook Pro Software Update 1.0. It will render the image useless on other machines.

digg story

8 comments:

Anonymous said...

You may not be in the clear just yet if you have Microsoft Office 2004 Powerpoint users. Your new image will crash Powerpoint when switching to Slide Show view on pre-Santa Rosa machines after updating to Mac OS X 104.10. I'm having to create two intel images becasue of it =(

PatGmac said...

I just tried it and I'm not having this problem. Is there something in your PPT files that would be different such as QT movies?

I used PPT's from here to test.

Would you be able to send me one of your PPT's and I can try it? My email is patgmac at gmail dot com

Anonymous said...

Here's the image recipe:
1. A working 10.4.9 image.
2. Upgraded with Santa Rosa essential software.
3. Upgraded to 10.4.10 (with or without MacBook Pro Software update).

If I restore the above image to any NON-Santa Rosa Mac (tested on 2.3Ghz MacBook Pro and Mac Pro), it causes Powerpint to crash whenever you switch to Slide Show view with any PPT file including new blank PPT files that are created when you open Powerpoint.

Crashreporter reports OPENGL as the thread that crashed.

The crash will NOT occur on Santa Rosa MacBook Pros.

The crash will NOT occur on NON-Stanta Rosa macs with 10.4.9 (8R2218) until you upgrade to 10.4.10 (v1.0 or 1.1).

Please confirm and tell me your joking ; )

PatGmac said...

I used the same procedure to create my image except I had more than essential software checked during the installer (I figured it couldn't hurt). There were a few other items that said "upgrade" and had a file size to them indicating they were in fact being upgraded.

You may have something else going on with your MBP image, perhaps something cached. I would try cleaning caches with something like MacHelpMate.

Anonymous said...

Patrick,
I am having this issue on the English Lab. PPT crashes all lab machines in Slide show view.
Damon

PatGmac said...

Ok, now I'm seeing it all over.
Posted here

John said...

Sorry for butting in to your discussion, but I found you while searching everywhere for talk of this problem. Have you made any progress in figuring out why ppt crashes in view mode on MacBook? I've spoken to both Apple and Microsoft and neither is willing to offer solutions. Thanks.

PatGmac said...

Yes. I posted our solution here